Getty Image purchases experiencing issues
Incident Report for Squarespace
Resolved
This incident has been resolved.
Posted Apr 25, 2024 - 19:31 EDT
Monitoring
The issue has been mitigated and we are monitoring the results.
Posted Apr 25, 2024 - 18:28 EDT
Update
We are working on a resolution.
Posted Apr 25, 2024 - 18:22 EDT
Update
We are continuing to work on a resolution.
Posted Apr 25, 2024 - 18:04 EDT
Update
We are continuing to work on a resolution.
Posted Apr 25, 2024 - 17:49 EDT
Update
Issue identified: working on a resolution.
Posted Apr 25, 2024 - 17:33 EDT
Update
We are continuing to investigate this issue.
Posted Apr 25, 2024 - 17:33 EDT
Investigating
We are currently investigating this issue.
Posted Apr 25, 2024 - 17:02 EDT
This incident affected: Third Party Services.