Errors creating trial sites, sites cannot be upgraded, errors when saving content
Incident Report for Squarespace
Resolved
This incident has been resolved, thanks for your patience.
Posted Aug 12, 2020 - 11:47 EDT
Monitoring
A fix for the current issues has been implemented, and we're monitoring the results.
Posted Aug 12, 2020 - 11:28 EDT
Update
We're now investigating issues related to saving changes on sites, in addition to trial site creation and site upgrade issues -- thank you for your patience.
Posted Aug 12, 2020 - 11:07 EDT
Update
We are also investigating issues with upgrading sites, which is likely related to errors with trial site creation.
Posted Aug 12, 2020 - 10:42 EDT
Investigating
We're investigating reports of errors when creating trial sites from our template store page.
Posted Aug 12, 2020 - 10:25 EDT
This incident affected: Site Editing and Accounts & Billing.