Connectivity Issues
Incident Report for Squarespace
Resolved
As of 12:30 EDT, this issue was resolved.
Posted Oct 12, 2017 - 12:49 EDT
Monitoring
We have implemented a fix and sites are loading normally for most users.
Posted Oct 12, 2017 - 12:26 EDT
Identified
We have identified a performance issue affecting the loading of websites and we are implementing a resolution.
Posted Oct 12, 2017 - 12:16 EDT