Get the Atom Feed or RSS Feed.

Acuity Scheduling - We are investigating reports of SMS messages being delayed in sending.

Incident Report for Squarespace

Resolved

This incident has been resolved.
Posted 1 year ago. Mar 26, 2024 - 12:45 EDT

Update

We are continuing to investigate this issue.
Posted 1 year ago. Mar 26, 2024 - 11:16 EDT

Investigating

We are currently investigating this issue.
Posted 1 year ago. Mar 26, 2024 - 09:50 EDT
This incident affected: Acuity Scheduling.