Get the Atom Feed or RSS Feed.

Domains Degradation

Incident Report for Squarespace

Resolved

This incident has been resolved.
Posted 1 year ago. Jan 23, 2024 - 18:09 EST

Update

We are continuing to work on a fix for this issue.
Posted 1 year ago. Jan 23, 2024 - 16:43 EST

Identified

Some domain management, registrations and transfers are experiencing degradation due to registry maintenance.
Posted 1 year ago. Jan 23, 2024 - 15:00 EST
This incident affected: Domains.