Service Ugrade Payment Issue
Incident Report for Squarespace
Resolved
This incident has been resolved.
Posted Feb 20, 2020 - 20:33 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 20, 2020 - 19:49 EST
Investigating
We're investigating an issue where users are unable to upgrade to paid service
Posted Feb 20, 2020 - 19:11 EST
This incident affected: Accounts & Billing.