Connectivity Issues

Incident Report for Squarespace

Resolved

This incident has been resolved.
Posted Jul 24, 2020 - 08:12 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 24, 2020 - 07:10 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 24, 2020 - 07:08 EDT

Update

We are continuing to investigate this issue.
Posted Jul 24, 2020 - 07:05 EDT

Investigating

We’re investigating issues connecting to Squarespace sites.
Posted Jul 24, 2020 - 06:54 EDT
This incident affected: Site Loading, Site Editing, and Commerce.