Connectivity issues with Squarespace sites
Incident Report for Squarespace
Resolved
This incident has been resolved.
Posted Apr 24, 2021 - 11:42 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 24, 2021 - 11:23 EDT
Update
We’re investigating issues connecting to Squarespace sites.
Posted Apr 24, 2021 - 11:15 EDT
Investigating
We are currently investigating this issue.
Posted Apr 24, 2021 - 11:07 EDT
This incident affected: Site Loading, Site Editing, Commerce, Domains, Email Campaigns, Scheduling, Accounts & Billing, Analytics, G Suite, Third Party Services, and Developer Platform.