Connectivity Issues
Incident Report for Squarespace
Resolved
Incident resolved - At 7:26PM ET we executed an operation on our database which caused some critical site settings data to become inaccessible to our applications. All sites and stores were affected. For many sites, visitors saw a cached version of the site. During this time, sites could not be edited and shopping was not possible.
We started restoring sites at 9:22PM ET. As of 9:56PM ET, the restore operations were completed and all affected websites are loading again. If you are having any issues with settings on your site or store, please contact Customer Support - https://support.squarespace.com/hc/requests/new
Posted Jun 09, 2020 - 00:08 EDT
Update
We are continuing to monitor for any further issues.
Posted Jun 08, 2020 - 22:09 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 08, 2020 - 22:01 EDT
Update
We are continuing to work on a fix for this issue.
Posted Jun 08, 2020 - 21:39 EDT
Update
We are continuing to work on a fix for this issue.
Posted Jun 08, 2020 - 21:09 EDT
Update
We are continuing to work on a fix for this issue.
Posted Jun 08, 2020 - 20:42 EDT
Update
We are continuing to work on a fix for this issue.
Posted Jun 08, 2020 - 20:08 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 08, 2020 - 19:46 EDT
Investigating
We’re investigating issues connecting to Squarespace sites.
Posted Jun 08, 2020 - 19:40 EDT
This incident affected: Site Loading, Site Editing, and Commerce.