Unable to advance trial signups
Incident Report for Squarespace
Resolved
We have identified the issue and released a fix.
Posted Feb 14, 2020 - 16:48 EST
Investigating
We have identified an issue where customers who register for new sites are unable to advance through the setup flow. We are currently investigating.
Posted Feb 14, 2020 - 14:23 EST
This incident affected: Site Editing.