Non-english templates store failing to load
Incident Report for Squarespace
Resolved
This incident has been resolved.
Posted Jun 22, 2022 - 02:40 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 22, 2022 - 02:37 EDT
Investigating
We're investigating issues with non-english Squarespace template stores appearing slow or unresponsive.
Posted Jun 22, 2022 - 02:34 EDT
This incident affected: Site Loading.