Customers unable to transfer domains
Incident Report for Squarespace
Resolved
This incident has been resolved.
Posted Dec 23, 2022 - 12:01 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 23, 2022 - 04:19 EST
Investigating
We are investigating an issue where customers are unable to transfer registered domains.
Posted Dec 23, 2022 - 03:06 EST
This incident affected: Domains.