Connectivity Issues
Incident Report for Squarespace
Resolved
This incident has been resolved.
Posted Jan 08, 2021 - 15:38 EST
Update
We are continuing to monitor for any further issues.
Posted Jan 08, 2021 - 15:29 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 08, 2021 - 15:28 EST
Update
We are continuing to investigate this issue.
Posted Jan 08, 2021 - 15:25 EST
Update
We are continuing to investigate this issue.
Posted Jan 08, 2021 - 15:23 EST
Investigating
We're investigating errors while connecting to some Squarespace sites.
Posted Jan 08, 2021 - 15:23 EST
This incident affected: Site Loading, Site Editing, Commerce, Domains, Accounts & Billing, and G Suite.