Campaigns pages not loading
Incident Report for Squarespace
Resolved
This incident has been resolved.
Posted Dec 10, 2019 - 19:40 EST
Update
We are continuing to monitor for any further issues.
Posted Dec 10, 2019 - 19:29 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 10, 2019 - 19:29 EST
Investigating
We are currently investigating an issue loading email campaigns pages.
Posted Dec 10, 2019 - 19:20 EST
This incident affected: Email Campaigns.