Elevated Error Rates
Incident Report for Squarespace
Resolved
This incident has been resolved and we have confirmed that error rates have returned to acceptable levels. Thank you for your patience.
Posted Nov 11, 2019 - 15:55 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 11, 2019 - 14:52 EST
Investigating
We are investigating reports of elevated error rates.
Posted Nov 11, 2019 - 14:46 EST
This incident affected: Site Loading.