Unable to start a trial or select a template from the international template store

Incident Report for Squarespace

Resolved

This incident has been resolved.
Posted Jun 17, 2022 - 13:59 EDT

Monitoring

The issue has been mitigated and we're monitoring the results.
Posted Jun 17, 2022 - 13:53 EDT

Update

We are continuing to investigate this issue with our translation partner.
Posted Jun 17, 2022 - 13:21 EDT

Update

We are continuing to investigate this issue with our translation partner.
Posted Jun 17, 2022 - 12:25 EDT

Update

We are continuing to investigate this issue.
Posted Jun 17, 2022 - 11:52 EDT

Investigating

We are currently investigating an issue where customers are unable to start a trial or select a template from the international template store.
Posted Jun 17, 2022 - 11:32 EDT
This incident affected: Site Editing.