Issues connecting to Weglot
Incident Report for Squarespace
Resolved
This incident has been resolved.

If you are still seeing a "Couldn’t connect to Weglot" error message in the Language and Region panel, follow these steps to resolve it:

1. Disconnect Weglot via Settings > Extensions > Connected Extensions.
2. Go back to the Language & Region panel, click Connect under Weglot.
3. In the Weglot connect workflow > login to the existing Weglot account > choose the project associated with the site rather than creating a new project.

For reference, here is the guide on this process:

https://support.squarespace.com/hc/en-us/articles/205809778-Creating-a-multilingual-site-in-Squarespace
Posted Nov 14, 2022 - 14:19 EST
Update
We are continuing to investigate this issue.
Posted Nov 14, 2022 - 12:34 EST
Update
We are continuing to investigate this issue.
Posted Nov 14, 2022 - 10:50 EST
Investigating
We're currently investigating issues when connecting Squarespace sites to Weglot.
Posted Nov 14, 2022 - 10:23 EST
This incident affected: Site Editing.