Get the Atom Feed or RSS Feed.

Connectivity Issues

Incident Report for Squarespace

Resolved

This incident has been resolved.
Posted 5 years ago. Nov 27, 2019 - 13:10 EST

Identified

The issue has been identified and we are working towards a solution. While we work our users may see intermittent slowness
Posted 5 years ago. Nov 27, 2019 - 12:17 EST

Update

We are continuing to investigate intermittent slowness on some sites.
Posted 5 years ago. Nov 27, 2019 - 11:31 EST

Update

We are continuing to investigate this issue.
Posted 5 years ago. Nov 27, 2019 - 10:47 EST

Investigating

We are investigating connectivity issues related to most Squarespace sites. We will provide more information as soon as possible.
Posted 5 years ago. Nov 27, 2019 - 10:15 EST
This incident affected: Site Loading.