Get the Atom Feed or RSS Feed.

Domain registration and management issues

Incident Report for Squarespace

Resolved

This incident has been resolved.
Posted 1 year ago. Oct 12, 2023 - 20:45 EDT

Update

We’ve confirmed that this issue is a result of an incident on one of our domain partners’ ends impacting domain management and registration for some domains. Our engineers are currently monitoring this issue as our domain registration partner works on a fix.
Posted 1 year ago. Oct 12, 2023 - 19:07 EDT

Identified

We've identified an issue impacting domain management and registrations for some domains. Domains ending in .com and .net are not affected. Engineers are working on a fix for this issue.
Posted 1 year ago. Oct 12, 2023 - 18:36 EDT
This incident affected: Domains.