Get the Atom Feed or RSS Feed.
Delays in domain transfers and registrations
Incident Report for Squarespace
Resolved
This incident has been resolved.
Posted 10 months ago. Apr 26, 2024 - 00:49 EDT
Monitoring
A fix has been implemented and we're monitoring results.
Posted 10 months ago. Apr 26, 2024 - 00:44 EDT
Update
The issue has been identified and a fix has been implemented.
Posted 10 months ago. Apr 26, 2024 - 00:41 EDT
Identified
The issue has been identified and a fix has been implemented.
Posted 10 months ago. Apr 26, 2024 - 00:25 EDT
Update
We’re continuing to investigate this issue.
Posted 10 months ago. Apr 26, 2024 - 00:12 EDT
Update
We’re continuing to investigate this issue.
Posted 10 months ago. Apr 25, 2024 - 23:56 EDT
Update
We’re continuing to investigate this issue.
Posted 10 months ago. Apr 25, 2024 - 23:39 EDT
Investigating
We are investigating an issue causing customers to see delays in domain registrations and transfers. This may also impact editing DNS records.
Posted 10 months ago. Apr 25, 2024 - 23:25 EDT
This incident affected: Domains.