Get the Atom Feed or RSS Feed.

Domain registrations and transfers failing

Incident Report for Squarespace

Resolved

The incident has been resolved. All domain registrations and transfers have resumed as normal.
Posted 11 months ago. May 07, 2024 - 19:43 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted 11 months ago. May 07, 2024 - 19:21 EDT

Update

We are continuing to investigate this issue.
Posted 11 months ago. May 07, 2024 - 19:05 EDT

Update

We are continuing to investigate this issue.
Posted 11 months ago. May 07, 2024 - 18:32 EDT

Investigating

Some domain registrations and transfers are failing. We are currently investigating the issue.
Posted 11 months ago. May 07, 2024 - 18:10 EDT
This incident affected: Domains.