Get the Atom Feed or RSS Feed.

Increased latency for domain operations

Incident Report for Squarespace

Resolved

This incident has been resolved.
Posted 1 year ago. Apr 16, 2024 - 17:38 EDT

Update

We are continuing to investigate this issue.
Posted 1 year ago. Apr 16, 2024 - 17:38 EDT

Investigating

We are currently investigating this issue.
Posted 1 year ago. Apr 16, 2024 - 16:44 EDT
This incident affected: Domain Reseller API.