Connectivity Issues
Incident Report for Squarespace
Resolved
This incident has been resolved.
Posted Nov 19, 2019 - 16:04 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 19, 2019 - 15:17 EST
Update
We are continuing to work on a fix for this issue.
Posted Nov 19, 2019 - 15:12 EST
Update
We are continuing to work on a fix for this issue.
Posted Nov 19, 2019 - 15:03 EST
Update
We are continuing to work on a fix for this issue.
Posted Nov 19, 2019 - 14:51 EST
Update
We are continuing to work on a fix for this issue.
Posted Nov 19, 2019 - 14:37 EST
Update
We are continuing to work on a fix for this issue.
Posted Nov 19, 2019 - 14:16 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 19, 2019 - 14:07 EST
Investigating
We are investigating connectivity issues related to most Squarespace sites. We will provide more information as soon as possible.
Posted Nov 19, 2019 - 14:04 EST
This incident affected: Site Loading.