Connectivity Issues
Incident Report for Squarespace
Resolved
This incident has been resolved.
Posted Sep 25, 2020 - 12:48 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 25, 2020 - 12:33 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 25, 2020 - 12:31 EDT
Update
We are continuing to investigate this issue.
Posted Sep 25, 2020 - 12:28 EDT
Update
We are continuing to investigate this issue.
Posted Sep 25, 2020 - 12:17 EDT
Update
We are continuing to investigate this issue.
Posted Sep 25, 2020 - 12:16 EDT
Investigating
We're investigating errors while connecting to some Squarespace sites.
Posted Sep 25, 2020 - 12:13 EDT
This incident affected: Site Loading, Site Editing, Commerce, Domains, Email Campaigns, Scheduling, Accounts & Billing, Analytics, and G Suite.