Get the Atom Feed or RSS Feed.

Payment button redirects to the previous page.

Incident Report for Squarespace

Resolved

This incident has been resolved.
Posted 1 year ago. Mar 25, 2024 - 18:15 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted 1 year ago. Mar 25, 2024 - 17:46 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted 1 year ago. Mar 25, 2024 - 17:40 EDT

Investigating

We are currently investigating this issue.
Posted 1 year ago. Mar 25, 2024 - 17:34 EDT
This incident affected: Acuity Scheduling.