Customers unable to log in to edit their sites
Incident Report for Squarespace
Resolved
We have resolved the underlying issue and customers are able to continue logging in and editing their websites as expected.
Posted May 24, 2019 - 18:20 EDT
Identified
Customers are unable to log in to edit their sites. We are investigating the issue.
Posted May 24, 2019 - 18:00 EDT
This incident affected: Site Loading.