Connectivity Issues

Incident Report for Squarespace

Resolved

This incident has been resolved.
Posted Feb 13, 2020 - 12:08 EST

Update

We are continuing to work on a fix for this issue.
Posted Feb 13, 2020 - 12:07 EST

Update

We are continuing to work on a fix for this issue.
Posted Feb 13, 2020 - 11:14 EST

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 13, 2020 - 11:01 EST

Investigating

We're investigating errors while connecting to some Squarespace sites.
Posted Feb 13, 2020 - 10:55 EST
This incident affected: Site Loading, Site Editing, and Commerce.