Image Upload Problems
Incident Report for Squarespace
Resolved
We believe that this issue will not recur at this time, but our engineers will continue to monitor the situation. We apologize for our brief interruption.
Posted Apr 23, 2020 - 22:22 EDT
Monitoring
We believe this issue has been resolved, but we will monitor the situation
Posted Apr 23, 2020 - 22:04 EDT
Investigating
We are currently investigating problems with uploading images.
Posted Apr 23, 2020 - 21:56 EDT
This incident affected: Site Editing.