Connectivity Issues
Incident Report for Squarespace
Resolved
This incident has been resolved.
Posted Jul 09, 2020 - 03:02 EDT
Investigating
We're investigating issues connecting to Squarespace sites.
Posted Jul 09, 2020 - 02:32 EDT
This incident affected: Site Loading and Accounts & Billing.