Image Processing Issues
Incident Report for Squarespace
Resolved
This incident has been resolved.
Posted Jul 19, 2017 - 15:55 EDT
Monitoring
We have deployed a fix and are monitoring the results.
Posted Jul 19, 2017 - 14:04 EDT
Investigating
We are investigating issues with image processing on our platform.
Posted Jul 19, 2017 - 13:12 EDT