Connectivity Issues
Incident Report for Squarespace
Resolved
This incident has been resolved.
Posted Nov 04, 2023 - 17:30 EDT
Update
We are continuing to monitor for any further issues.
Posted Nov 04, 2023 - 15:50 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 04, 2023 - 15:22 EDT
Investigating
We're investigating errors while connecting to some Squarespace sites.
Posted Nov 04, 2023 - 14:55 EDT
This incident affected: Site Loading.