Get the Atom Feed or RSS Feed.
Migration delays caused by domain forwarding
Incident Report for Squarespace
Resolved
This incident has been resolved.
Posted 10 months ago. Apr 19, 2024 - 13:19 EDT
Investigating
We are currently investigating an issue where recently users cannot manage or view their DNS records.
Posted 10 months ago. Apr 19, 2024 - 13:00 EDT
This incident affected: Domains.