Connectivity Issues

Incident Report for Squarespace

Resolved

This incident has been resolved.
Posted May 27, 2020 - 11:18 EDT

Investigating

Some customers may be experiencing DNS-related connectivity issues. We are investigating.
Posted May 27, 2020 - 11:08 EDT
This incident affected: Domains.