Merchants unable to purchase shipping labels
Incident Report for Squarespace
Resolved
A fix has been implemented. This incident is now resolved
Posted May 24, 2022 - 13:41 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted May 24, 2022 - 13:13 EDT
Investigating
We are investigating reports of merchants being unable to purchase shipping labels.
Posted May 24, 2022 - 12:49 EDT
This incident affected: Commerce.