Get the Atom Feed or RSS Feed.

Acuity Scheduling / Intermittent errors accessing Client Scheduling Page

Incident Report for Squarespace

Resolved

This incident has been resolved.
Posted 1 year ago. Feb 27, 2024 - 14:57 EST

Investigating

We are currently investigating this issue.
Posted 1 year ago. Feb 27, 2024 - 14:52 EST
This incident affected: Acuity Scheduling.