Connectivity issues
Incident Report for Squarespace
Resolved
Connectivity and performance has returned to normal.
Posted Oct 12, 2016 - 12:56 EDT
Identified
Connectivity is improving. Pages are loading slower than normal.
Posted Oct 12, 2016 - 12:16 EDT
Investigating
We are investigating reports of connectivity issues affecting all sites.
Posted Oct 12, 2016 - 11:00 EDT