Get the Atom Feed or RSS Feed.

Acuity Scheduling - Admins having difficulty scheduling from mobile web view

Incident Report for Squarespace

Resolved

This incident has been resolved.
Posted 1 year ago. Nov 09, 2023 - 07:38 EST

Investigating

We are currently investigating this issue.
Posted 1 year ago. Nov 09, 2023 - 06:37 EST
This incident affected: Acuity Scheduling.