Some sites loading slowly/not loading
Incident Report for Squarespace
Resolved
This incident has been resolved.
Posted May 21, 2020 - 15:44 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 21, 2020 - 15:37 EDT
Identified
The new issue has been identified and a fix is being implemented.
Posted May 21, 2020 - 15:27 EDT
Update
We are continuing to investigate this issue.
Posted May 21, 2020 - 15:10 EDT
Investigating
We are currently investigating a new issue that was discovered while we were remediating a previous problem.
Posted May 21, 2020 - 15:01 EDT
Update
We are continuing to monitor for any further issues.
Posted May 21, 2020 - 14:38 EDT
Update
We are continuing to monitor for any further issues.
Posted May 21, 2020 - 14:18 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 21, 2020 - 14:07 EDT
Update
We are continuing to work on a fix for this issue.
Posted May 21, 2020 - 13:54 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted May 21, 2020 - 13:36 EDT
Investigating
We're investigating reports of some Squarespace sites loading slowly.
Posted May 21, 2020 - 13:36 EDT
This incident affected: Site Loading.