Form submissions to Google Drive are not populating
Incident Report for Squarespace
Resolved
This issue has been resolved.
Posted Jul 17, 2020 - 10:43 EDT
Identified
We've identified the issue and are working on a fix.
Posted Jul 17, 2020 - 10:31 EDT
Investigating
We're investigating an issue with form submissions not populating to Google Drive.
Posted Jul 17, 2020 - 10:12 EDT
This incident affected: Site Loading.