Delayed delivery of email messages from Squarespace.

Incident Report for Squarespace

Resolved

This incident has been resolved.
Posted May 19, 2025 - 13:23 EDT

Update

This issue has been mitigated. We are continuing to monitor for any further issues.
Posted May 19, 2025 - 11:00 EDT

Update

This issue has been mitigated. We are continuing to monitor for any further issues.
Posted May 19, 2025 - 09:36 EDT

Monitoring

This issue has been mitigated. We are continuing to monitor for any further issues.
Posted May 19, 2025 - 08:47 EDT

Update

We are continuing to investigate this issue.
Posted May 19, 2025 - 03:03 EDT

Update

We are continuing to investigate this issue.
Posted May 19, 2025 - 02:46 EDT

Update

We are continuing to investigate this issue.
Posted May 19, 2025 - 02:25 EDT

Update

We are continuing to investigate this issue.
Posted May 19, 2025 - 02:09 EDT

Update

We are continuing to investigate this issue.
Posted May 19, 2025 - 01:51 EDT

Update

We are continuing to investigate this issue.
Posted May 19, 2025 - 01:36 EDT

Update

We are continuing to investigate this issue.
Posted May 19, 2025 - 01:21 EDT

Update

We are continuing to investigate this issue.
Posted May 19, 2025 - 00:41 EDT

Update

We are continuing to investigate this issue.
Posted May 19, 2025 - 00:24 EDT

Update

We are continuing to investigate this issue.
Posted May 19, 2025 - 00:05 EDT

Update

We are continuing to investigate this issue.
Posted May 18, 2025 - 23:39 EDT

Update

We are continuing to investigate this issue.
Posted May 18, 2025 - 23:11 EDT

Update

We are continuing to investigate this issue.
Posted May 18, 2025 - 22:50 EDT

Update

We are continuing to investigate this issue.
Posted May 18, 2025 - 22:15 EDT

Update

We are continuing to investigate this issue.
Posted May 18, 2025 - 21:53 EDT

Update

We are continuing to investigate this issue.
Posted May 18, 2025 - 21:31 EDT

Update

We are continuing to investigate this issue.
Posted May 18, 2025 - 21:10 EDT

Update

We are continuing to investigate this issue.
Posted May 18, 2025 - 20:31 EDT

Update

We are continuing to investigate this issue.
Posted May 18, 2025 - 20:10 EDT

Update

We are continuing to investigate this issue.
Posted May 18, 2025 - 19:53 EDT

Update

We are continuing to investigate this issue.
Posted May 18, 2025 - 19:34 EDT

Update

We are continuing to investigate this issue.
Posted May 18, 2025 - 19:14 EDT

Update

We are continuing to investigate this issue.
Posted May 18, 2025 - 16:51 EDT

Update

We are continuing to investigate this issue.
Posted May 18, 2025 - 16:32 EDT

Update

We are continuing to investigate this issue.
Posted May 18, 2025 - 16:17 EDT

Update

We are continuing to investigate this issue.
Posted May 18, 2025 - 16:01 EDT

Update

We are continuing to investigate this issue.
Posted May 18, 2025 - 15:46 EDT

Update

We are continuing to investigate this issue.
Posted May 18, 2025 - 15:30 EDT

Update

We are continuing to investigate this issue.
Posted May 18, 2025 - 15:15 EDT

Update

We are continuing to investigate this issue.
Posted May 18, 2025 - 15:01 EDT

Update

We are continuing to investigate this issue.
Posted May 18, 2025 - 14:43 EDT

Investigating

We are currently investigating an issue where users are experiencing delays in receiving email messages from Squarespace.
Posted May 18, 2025 - 14:25 EDT
This incident affected: Accounts & Billing.