Get the Atom Feed or RSS Feed.

Sites are not loading images and CSS

Incident Report for Squarespace

Resolved

This incident has been resolved and we have confirmed that all systems are operational. Thank you for your patience.
Posted 5 years ago. Sep 24, 2019 - 13:12 EDT

Monitoring

A resolution has been implemented and we are monitoring closely before resolving the issue.
Posted 5 years ago. Sep 24, 2019 - 12:54 EDT

Identified

We have identified an issue with loading images and CSS, which is impacting both viewing and editing sites. We are implementing a resolution.
Posted 5 years ago. Sep 24, 2019 - 12:36 EDT

Investigating

We are investigating connectivity issues related to most Squarespace sites. We will provide more information as soon as possible.
Posted 5 years ago. Sep 24, 2019 - 12:25 EDT
This incident affected: Site Loading.