Squarespace Scheduling Admin - Some payment amounts are displaying incorrectly on the Admin side of Scheduling
Incident Report for Squarespace
Resolved
This incident has been resolved.
Posted Jun 16, 2022 - 14:33 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 16, 2022 - 14:01 EDT
Investigating
We are currently investigating this issue.
Posted Jun 16, 2022 - 13:26 EDT
This incident affected: Acuity Scheduling.