Domain registration and management issues
Incident Report for Squarespace
Resolved
The issue has been mitigated and resolved
Posted Oct 21, 2023 - 03:31 EDT
Update
We are continuing to investigate this issue.
Posted Oct 21, 2023 - 03:09 EDT
Investigating
We are currently investigating issues with the Domain registration and management issues.

Registration
Transfers
DNS management
Domain forwarding
Google Workspace registration
Posted Oct 21, 2023 - 03:04 EDT
This incident affected: Domains and Google Workspace.