Customers are unable to signup for G Suite services
Incident Report for Squarespace
Resolved
This incident has been resolved.
Posted Jul 23, 2020 - 21:40 EDT
Update
We are continuing to monitor for any further issues.
Posted Jul 23, 2020 - 21:20 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 23, 2020 - 19:40 EDT
Investigating
We are investigating an issue causing customers who are unable to create new G Suite subscriptions or view their existing subscription.
Posted Jul 23, 2020 - 18:09 EDT
This incident affected: G Suite.