Domain registration, update and transfer
Incident Report for Squarespace
Resolved
This incident has been resolved and we have confirmed that error rates have returned to acceptable levels. Thank you for your patience.
Posted Feb 08, 2019 - 12:47 EST
Monitoring
The incident with domain registration, update and transfer has been resolved and we are actively monitoring error rates.
Posted Feb 08, 2019 - 12:40 EST
Identified
Customers are unable to register, update or transfer domains. Our registrar is investigating the issue.
Posted Feb 08, 2019 - 09:47 EST
This incident affected: Domains.