Connectivity Issues
Incident Report for Squarespace
Resolved
This incident has been resolved.
Posted Jul 12, 2022 - 17:30 EDT
Investigating
We're investigating errors while connecting to some Squarespace sites.
Posted Jul 12, 2022 - 15:43 EDT
This incident affected: Site Loading.