Commerce Checkout Issues
Incident Report for Squarespace
Resolved
This incident has been resolved.
Posted May 24, 2017 - 18:45 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 24, 2017 - 18:03 EDT
Investigating
We are currently investigating an issue affecting credit card input on all Commerce checkout pages.
Posted May 24, 2017 - 17:38 EDT