Connectivity Issues
Incident Report for Squarespace
Postmortem

On June 3rd, 2020, many Squarespace sites had connectivity issues for approximately 45 minutes, across a three hour window. We sincerely apologize to our customers and their visitors for the disruption caused.

At 7:04PM ET, our engineers were alerted to an unusually disruptive distributed denial of service (DDoS) event. A DDoS event occurs when multiple computer systems intentionally flood the resources of a website, attempting to make the site unavailable.

DDoS events are very common on the internet, and we have a lot of practice in detecting and responding to them. However, these events are challenging and unpredictable in nature. This particular event was unusually large and complex. Although our team acted quickly, our usual processes and tools weren’t immediately effective at protecting our systems. As a result, we had roughly 45 minutes of downtime over a three hour window.

We take outages very seriously. We realize that an outage of this duration is very disruptive to our customers. We have already made improvements to our systems in response to this incident. We are conducting an internal retrospective and will make further changes to improve our resilience to these kinds of events.

Uri Fridman, Squarespace Director of Security

Posted Jun 04, 2020 - 15:20 EDT

Resolved
This incident has been resolved.
Posted Jun 03, 2020 - 23:31 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 03, 2020 - 21:51 EDT
Update
We are continuing to work on a fix for this issue.
Posted Jun 03, 2020 - 21:18 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 03, 2020 - 20:55 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 03, 2020 - 20:38 EDT
Investigating
We’re investigating issues connecting to Squarespace sites.
Posted Jun 03, 2020 - 20:19 EDT
This incident affected: Site Loading, Site Editing, and Commerce.