Get the Atom Feed or RSS Feed.

Acuity Scheduling - We are experiencing a disruption with one of our payment processors, transactions and other integrations may be impacted

Incident Report for Squarespace

Resolved

This incident has been resolved.
Posted 1 year ago. Feb 06, 2024 - 13:12 EST

Investigating

We are currently investigating this issue.
Posted 1 year ago. Feb 06, 2024 - 11:33 EST
This incident affected: Acuity Scheduling.