Get the Atom Feed or RSS Feed.

Account Dashboard Issues

Incident Report for Squarespace

Resolved

This incident has been resolved.
Posted 1 year ago. Apr 09, 2024 - 12:04 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted 1 year ago. Apr 09, 2024 - 11:51 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted 1 year ago. Apr 09, 2024 - 11:30 EDT

Investigating

We are currently investigating an issue with domains not displaying in Account Dashboards.
Posted 1 year ago. Apr 09, 2024 - 11:10 EDT
This incident affected: Domains and Accounts & Billing.